Chartboost Mediation Adapter v2.0.0

Adapter for allowing the Millennial Media SDK to mediate to Chartboost for interstitial ads.

Requirements

  • MM Ad SDK v6.6.0
  • Chartboost SDK v6.6.2

Compatibility

  Chartboost SDK v6.6.2
MM Ad SDK v6.6.0 Chartboost Mediation Adapter v2.0.0

Integration

Mediation to the Chartboost SDK is handled by the MM Ad SDK and mediation adapter. Integrating application needs to add the appropriate frameworks per the standard integration guide from Chartboost.

1. Download the Chartboost SDK from the Chartboost developers site.
2. Integrate the Chartboost SDK and MM Ad SDK according to their respective integration guides and include libMMChartboostAdapter.a
3. Initialize Chartboost before you make an ad request, AppDelegate is an ideal place for this.
    [Chartboost startWithAppId:@"YOUR_CHARTBOOST_APP_ID"
                  appSignature:@"YOUR_CHARTBOOST_APP_SIGNATURE"
                      delegate:self];    

References

Release Notes

v2.0.0 - September 20, 2017

  • Updated to support MM SDK v6.6.0. Note that this adapter will not work with previous versions of the MM SDK

v1.0.2 - April 11, 2017

  • Added bitcode support

v1.0.0 - August 30, 2016

  • Initial release of the MM to Chartboost mediation adapter